W-Lan trennt sich auf dem Handy immer

S.G. shared this question 2 years ago
Need Answer

W-Lan Verbindung funktioniert mit einem Android-Handy im Automatik- sowie im Manuellmodus nicht wie gewünscht.

Jedes mal erscheint die Meldung "Im WLAN-Netzwerk anmelden". Nach dem anmelden besteht die Verbindung nur 2-3 Minuten. Es erscheint: "Dieses Netzwerk wurde getrennt. Ihre Anmeldung ist abgelaufen."

E-Blocker OS ist aktuell.


2269bc42e13e1f13f28798bef2cf9cb6

43c46396e337120e55c3491ea1628b3c


Lösungsvorschläge?


Grüsse,

S.G

Comments (47)

photo
1

Hi S.G.,


which router do you use?


Best regards

photo
1

Hi Tim.

I have the same behavior.

I use a Netgear wndr 3600 with the newest DD-WRT build.

The behavior is reproduceable on three android devices with both lollipop and marshmallow as well as with one windows 10 pc.

The device connects, I can reach the Internet, eblocker overlay appears correctly in the browsers. After some minutes the device shows that I have no Internet connection and should log in to the network via a webpage (204?) and switches to mobile data instead.

Disconnect WLAN and reconnect yields the same results.


Any ideas?


All the best,

/Erik

photo
1

Hallo,


Fehler bleibt bestehen mit Update auf Eblocker 0.8.7-2.

Router ist ein Netgear WNDR 4500


Mfg

S.G

photo
1

We are still trying to reproduce the problem. We have tested Android 4.1.2, 4.3 and 4.4.2 on a Netgear WNDR 3700 with DD-WRT so far and WiFi devices stay connected.

photo
1

Is the setting "Avoid poor connections" enabled on your Android device? You can find it in Settings, WiFi, [Overflow Menu], Advanced.

photo
1

Hallo Tim,

Diese Einstellung kann ich bei mir nicht aktivieren.

i can not activate this Setting.

795c2cab52e1ac7316a739d9c07722a3

2d65efd7719b7d4f01fcd393cff22d1f

MfG

S.G

photo
1

Interesting effect: I switched the board from a Raspberry PI 2 to a Banana PI Pro. The Raspberry ran in Automatic config, which did not work for the Banana. However with the Banana in manual config the Android devices and the others I have tested until now work like a charm.

Strange but at least I got my system going. If there is some SW or config difference between the Banana and Raspberry PI builds, that might be a help for faultfinding

All the best,

/Erik

photo
1

Interesting point!

Maybe (some versions of) Android defends against hacking methods (ARP poisoning that eBlocker does in auto mode)?!

Could some of you do test/confirm if the issue persists when disabling eBlockers "Automatic" mode in Network panel?

edit: Your browsing won't be filtered then, it's just to figure out if the ARP poisoning does cause the disconnects.

photo
1

Hi F.R.,

Falconcrest (see below) has the same problem and he is already using the manual mode (7490 problem).


Best regards

photo
1

Was ich gerade aus langeweile probiert habe:

Im eBlocker-Menü unter Geräte mein Handy deaktiviert. Wlan lässt sich verbinden und bleibt verbunden. Die Verbindung wird nicht mehr nach ca. 3min von selbst getrennt.

Aktiviere ich mein Handy im Eblocker wieder, dann bleibt die Verbindung bestehen, aber die Filterung ist nicht aktiv. Erst nachdem die Wlan-Verbindung getrennt / wieder verbunden wird tauchen wieder Verbindungsprobleme auf.

photo
1

Was this with eBlocker in manual mode?

photo
1

Ja genau, eBlocker befand sich im manual Mode.

photo
1

@ Tim

Konntet ihr das Problem reproduzieren?

Fehler besteht weiterhin...

photo
1

Problem besteht mit dem neusten eBlocker OS 0.8.9-2 weiterhin.

Ist in absehbarer Zeit eine Lösung in Sicht?


MFG S.G.

photo
1

Hallo,

Das Verbindungsproblem scheint nun endlich behoben. Mein Smartphone hat sich anstandslos über eBlocker verbunden. Leider besteht jetzt ein neues Problem: https://forum.eblocker.com/topic/nach-update-auf-0-9-0-15-werden-keine-http-webseiten-mehr-geladen


MfG S.G.

photo
photo
1

Hallo Tim,

Router ist ein Netgear WNDR 4500, Firmware ist original und aktuell.

So wie ich es gelesen habe geht es mir wie Erik, trennen und wieder verbinden führt zum selben Ergebnis. Auch bringt es nichts die Verbindung zu löschen und neu hinzuzufügen.

Es handelt sich bei mir um Android 4.3 (Galaxy S3).

Desweitern schalte ich über Nacht immer den Internetzugang (Modem, Router + Eblocker) ab. Auf dem PC wird mir dann beim hochfahren eine Meldung für die Netzwerkeinstellungen angezeigt. Mittlerweilen bin ich bei Netzwerk 12!

ebd6814c50e82b0d27cc0e92a7309429

Wo könnte der Fehler hier liegen?

MfG

S.G

photo
1

There is an issue with Banana Pi M2 boards. Each time the eBlocker reboots, it has a new MAC address and Windows creates a new network.


This will be fixed in our next release 0.8.7.

photo
1

Hab erst jetzt gemerkt dass ich am falschen Ort geantwortet habe.


Danke für den Hinweis bezüglich MAC-Adresse.

Zurück zum eigentlichen Problem:

Das Problem mit der Wlan-Verbindung besteht auch mit einem anderen Android Handy.

photo
photo
1

Das WLan-Problem kann ich so bestätigen.

Die 7490 ohne DHCP und der eBlocker mit DHCP im Manuell-Modus funktionieren mit diversen Laptop`s gut, aber die Androiden wollen nicht mit der eBlocker-IP als Gateway zusammen arbeiten.

photo
1

Hi Falconrest,

which Android devices (and which Android versions) are you using?


Best regards

photo
1

Hello, there are 3 devices Samsung Galaxy S3 with 1x CyanogenMod 13.0 Marshmallow 6.0.1 and 2x BlissPop Lollipop 5.1.1, 3 devices Samsung Galaxy S2 with 2x CyanogenMod 12.1 Lollipop 5.1.1 and 1x Resurrection Remix Lollipop 5.1.1 and 1 device Samsung Galaxy Tab 2 with 1x OmniRom Lollipop 5.1.1 in use. None of the devices work with Wi-Fi, if the eBlocker as the getaway. This must be so, because a 7490 in use. Best regards, Falconcrest.

photo
1

Hi Falconcrest,


have you seen Erik's post:


"Interesting effect: I switched the board from a Raspberry PI 2 to a

Banana PI Pro. The Raspberry ran in Automatic config, which did not work

for the Banana. However with the Banana in manual config the Android

devices and the others I have tested until now work like a charm. Strange

but at least I got my system going. If there is some SW or config

difference between the Banana and Raspberry PI builds, that might be a

help for faultfinding"


Do you have a raspberry board?


Best regards

photo
1

Hello Tim,

I switched also now from the raspberry pi 2 to the banana pi M2, but the problem has not changed. 4 notebooks work without problems with the eblocker as gateway. I can not find a solution.

Regards, Falconcrest.

photo
1

I have two Oneplus One Android Phones (runniny Cyanogenmod) and they work perfectly with eBlocker in automatic mode. (I know does not help, but it may not be a general Android problem...)

photo
photo
1

Meine Android Devices funktionieren im Automatischen Modus recht gut, aber ein Amazon Firestick streikt nachvollziehbar permanent, egal ob ich für ihn explizit den eBlocker deaktiviere oder nicht.

photo
1

probierst Du bitte auch mal, ob er funktioniert, wenn Du den "Automatic" mode des eBlockers ausschaltest? Der Firestick ist auch Android-based.

photo
photo
1

Hi m4gr01no,

if you disable a device, eBlocker will ignore it completely. Please restart the stick (for example plug it out and in again) after disabling.


Best regards

photo
1

Das ist kein Spezifikum von Android oder Win, gestern Abend habe ich das in guten denglisch beschriebene Problem auch mit iOS 9.2.1 und iPhone erlebt. Mein Mobile kannte zwar noch die WLAN, konnte sich aber nicht mehr damit verbinden bzw. die Verbindung hielt nur wenige Minuten. Und da ich einen RasPI und eblocker 0.8.7 habe, scheint das Problem noch nicht gefixt zu sein. Übrigens kann es auch nicht am Netgear Router liegen, meinen Router ziert ein angebissener Apfel

photo
1

WLAN Verbindungsproblem zeigt sich bei Android 4.4.2 aber nicht bei Android 5.1.1; Umgebung: Rasperry Pi2 mit AVM 7490, manuell nach Anweisung konfiguriert.

photo
1

Hallo,

ich kann dies auch nachvollziehen. Ich habe hier ein Nexus6 und Nexus7. Beide auf der aktuellsten Android-Version 6.0.1. Ich habe die Fritzbox 7490 in Verwendung. An diese ist per LAN eine WLAN-Repeater angeschlossen (LAN-Brücke). Wobei das WLAN in der Fritzbox allerdings deaktiviert ist.

eBlocker ist auf einem Banana Pi M2 installiert. Automatic-Mode ist deaktiviert und der DHCP-Server wurde ebenfalls auf der Fritzbox deaktiviert und auf dem Banana Pi M2 aktiviert.

Auf dem Nexus6 habe ich neben dem WLAN-Icon ein Ausrufezeichen. Es wird angezeigt "Verbunden, kein Internet". Surfen geht trotzdem. Allerdings bekomme ich das eBlocker-Icon nicht angezeigt und das Filtering funktioniert natürlich auch nicht, da das Telefon über LTE im Netz hängt.

Deaktiviere ich das Device in der GUI auf meinem Notebook, verschwindet auch das Ausrufezeichen auf dem Nexus6/7.

Stelle ich den eBlocker auf "Automatisch" bekomme ich auch gelegentlich das Ausrufezeichen. Allerdings funktioniert das Filtering dann.

Das scheint offensichtlich ein Bug zu sein und noch ein schwerwiegender dazu.

Verwendet wird das eBlocker OS 0.8.9-2.

Als Workaround habe ich das Nexus6/7 jetzt deaktiviert. Eigentlich hatte ich das Projekt begonnen, damit ich auch auf mobilen Geräten Filter kann. Ich hoffe, das Problem wird noch gelöst. Die 60€ für das Abo wären es mir sonst nicht wert.

Gruß,

Alex

photo
1

Das kann so nicht stimmen*.

Ich tippe mal: Du betreibst einen Accesspoint an einem LAN-Port der F!B


Gruss

*

- per LAN eine WLAN-Repeater <-- technisch unmöglich

- LAN-Brücke <-- unwahrscheinlich, benötigte ein Gegenstück

photo
1

Der Modus nennt sich LAN-Brücke. LAN-Kabel an FB. Wobei das WLAN auf der FB deaktiviert ist. Alle Geräte melden sich am "Access Point" (1750E).

photo
1

OMG! Hab's grade gefunden .

In Tat und Wahrheit betreibst Du einen simplen AP im LAN. Aber LAN-Brücke klingt natürlich cooler :)

photo
1

Nennt AVM so.

photo
photo
1

mein Tab S2 trennt sich auch immer, ich habe die neue 0.9 beta, einen Raspery PI, AVM 7490, und auch einen WLAN Repeater. eBlocker steht auf manuel, Tab S2 steht auch auf manuel

photo
1

Hallo,

Bei mir ist der Fehler mit dem Update auf eBlocker 0.9.0-15 gelöst. Hast du dein Tab und den eBlocker nach dem Update schonmal neugestartet?


MfG S.G.

photo
1

das bringt alles nichts, ich hatte noch Hoffnung das die 0.9 Version besser wird, aber jetzt gebe ich das Projekt auf

photo
1

In den eBlocker-Einstellungen hat es einen Schalter für diese Problematik, hast du den gefunden? Ist auch dort wo der selbige für den HTTP-Ref. Bin gerade unterwegs,sonst hätt ich einen Screenshot angehängt

photo
1

Anbei ein Screenshot: 0baa0aee014fa48a7ff908f003db7055

photo
1

Guten Morgen, ich habe eine ähnliche Kombination: Rasperry, 7490, Samsung Handy und Tablet. Allerdings kein Repeater, sondern DHCP auf den eBlocker umgestellt laut Anleitung für die 7490.

Danach wurden IP Adressen tw. neu und doppelt vergeben, so auch für mein Tablet - was natürlich zu Verbindungsabbrüchen geführt hat. Mal nach sowas geschaut?

Ansonsten habe ich mit der 09er Beta eher mehr Probleme. Android Geräte, die vorher problemlos liefen, zeigen im WLAN Symbol nun ein Fragezeichen und melden ständig "Bei WLAN anmelden". Wenn man das antippt, wird aber kein WLAN angezeigt. Und trotz dieser Meldung besteht eine Verbindung, man kommt also ins Internet. Geräte im Standby brauchen nach dem Aktivieren immer Zeit, bis sie sich wieder mit dem WLAN verbinden. Somit kein riesiges Problem, aber (neben anderen Problemen wie VPN) einfach sehr nervig für ein Produkt, bei dem ein "funktioniert direkt nach dem Auspacken" angepriesen wird...

photo
1

ich habe das deaktiviert und trotzdem verliert mein Tab die Verbindung, bei anderen habe ich es noch nicht versucht. Wie habt Ihr Eure Einstellungen? der eBlocker steht auf manuel, und die andere auch auf statisch, oder habt ihr die wo drauf zugreifen auf DHCP? wenn ich die Clienten auf DHCP einstellen kann sein das er Trotz das ich es bei meiner AVM 7490 deaktiviert habe, diese als Gateway nimmt, nicht immer aber ab und an. Wie kann ich den eBlocker zurück setzen? dann verliere ich doch wieder die Lizenzen oder? und die 0.9 Version neu drauf spielen, woher bekomme ich diese Version?

photo
1

Verstehe nicht ganz - was genau hast Du wo deaktiviert?

DHCP ist in meiner 7490 abgeschaltet und im eBlocker aktiviert.

Mit Ausnahme eines PCs, auf dem diverse Funktionen nicht mehr gegeben waren (und dem ich IP / Gateway statisch zugewiesen habe) holen sich alle andere Geräte (also auch Handys, Tablets) ihre IP vom DHCP.


Das mit der Lizenz würde mich auch interessieren - wenn man das Gerät völlig neu aufsetzt, ist dann noch eine Aktivierung möglich?

photo
1

komisch, wenn ich auf DHCP stehen habe und er hat zufällig mal den eBlocker als Gateway rasugesucht, dann hält der die Verbindung, wenn ich statisch eingebe zeigt er gleich an das Wlan Netzwerk ging verloren ich solle mich anmelden. Schade das mein kostenloser Lizenz Key nur bis zum 31.03.2016 geht, ich hätte das gerne weiter getestet, aber bevor ich nicht sicher bin ob das ganze funktioniert werde ich kein Geld dafür ausgeben, was wohl verständlich ist oder ? :-) schöne Ostern Euch allen

photo
1

Bei mir ist die Funktion "Google Captive Portal Check" eingeschaltet. Bei meinem Router ist DHCP deaktiviert, eBlocker ist im Manual-Mode und DHCP ist aktiviert.

photo
photo
1

Problem besteht weiterhin

Konfiguration:

Banana Pi M2+ eblocker Firmware 0.9.3.8

Android Galaxy S7 6.0.1


dagegen:

SONY Tablet Xperia Z2 mit Android 6.0.1 --> geht problemlos, keine Trennung und Abfrage nach Bestätigung!!!

(im gleichen ) LAN

photo
1

Bei einigen geht es, bei anderen nicht.


Wir arbeiten daran und kreisen das Problem weiter ein.


Frage: Kannst Du, auch wenn die Meldung kommt, dennoch im Netz surfen, ect? Also die Meldung einfach nicht beachten und weiter arbeiten...

photo
1

Hi Tim,


NEIN, kann nicht surfen und nichts abrufen (nur über mobile Daten ...)

Wir haben zwei identische S7 mit exakt gleicher Firmware im Netz.

Beide Geräte zeigen gleiches Verhalten --> "tippen Sie, um sich mit WLAN xxxx" zu verbinden


Das Sony Tablet zeigt - wie schon gesagt - nicht dieses Verhalten!

photo