VPN-Netz Verbindung stürzt ab

mad shared this question 8 months ago
Need Answer

Das eingerichtete VPN-Netz funktioniert leider nicht ständig; Verbindung bricht später ab!

Hier die Fehlermeldung:


Sat Feb 11 16:25:03 2017 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

Sat Feb 11 16:25:03 2017 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this

RTNETLINK answers: Operation not permitted

Sun Feb 12 00:25:43 2017 Linux ip addr del failed: external program exited with error status: 2


Eine Änderung der Verbindung ist nicht möglich. Muss die Verbindung löschen und anschließend wieder neu einrichten. Fehler tritt dann später wieder auf.


Kann der Support für Abhilfe schaffen?

Hat jemand ähnliche Erfahrungen gemacht?

Comments (6)

photo
1

hat keiner eine Lösung?

Echt lästig...

photo
1

Um welchen Anbieter handelt es sich?

Ist die Verbindung dauerhaft eingerichtet, oder wird diese nur ab und zu genutzt?


Ich nutze zum Beispiel keine dauerhafte VPN Verbindung, da die meisten VPN Server die Geschwindigkeit doch extrem drosseln.

photo
1

Habe das gleiche Problem. Bei mir ist das VPN dauerhaft an. Tritt der Fehler auf, dann kann die Verbindung nicht mehr aufgebaut werden, es hilft nur noch ein Reboot des eBlockers. Eine alternative Verbindung zu einem anderen VPN Server vom gleichen Anbieter (ProtonVPN) funktioniert jedoch. Nachdem dann alle durch waren, bleibt wirklich nur noch der Reboot. Wäre es möglich einem Gerät eine Liste von VPN Verbindungen zuzuweisen, sodass nicht sofort die ganze Verbindung abbricht?

Hier noch das Fehlerlog beim erneuten Verbindungsaufbauversuch:

Sat Oct 7 09:21:32 2017 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts RTNETLINK answers: Operation not permitted

Sat Oct 7 09:21:34 2017 Linux ip addr del failed: external program exited with error status: 2

Sat Oct 7 09:21:35 2017 ERROR: Cannot ioctl TUNSETIFF tun: Operation not permitted (errno=1)

photo
1

Der VPN Provider scheint die Netzwerkkonfiguration zu ändern, was der eBlocker nicht ausführen kann.

Das kann zum Beispiel passieren, wenn Sie statt einem VPN Server ein Gruppe von VPN Servern nehmen.

Beispiel für eine Gruppe: Amsterdam.ovpn

Beispiel für einzelne Server: Amsterdam1.ovpn, Amsterdam2.ovpn, Amsterdam3.ovpn

Wenn Ihr VPN Anbieter nun die Verbindung ändert, weil zB Amsterdam1.ovpn Probleme macht, und Ihre Verbindung nun zum Server Amsterdam2.ovpn ändern, kann das zu Problemen mit dem eBlocker führen.

Testen Sie ein mal von Ihrem VPN Anbieter eine Verbindung zu einem Server, sofern er das anbietet.

photo
1

Ehrlich gesagt Tim, kann ich deinen Ausführungen nicht ganz folgen. Es ist ja nun mal so, dass der "eBlocker" (eB) nicht ganz ausgereift ist und nicht zu 100% das Ergebnis bringt, was er laut Werbung verspricht.


VPN gibt es ja nun schon mal etwas länger als den eB. Deshalb haben viele User auch eine spezielle Einwahl-Software installiert im OS. Und diese Software installiert immer eine virtuelle Netzwerk(-Komponente) mit einer neuen MAC-Adresse. Anders würde u. könnte VPN gar nicht funktionieren.


Das passiert im eB genauso und es ist nichts Neues, wenn der VPN-Provider bei Problemen die Verbindung umstellt. Ohne eB funktioniert es bei mir z.B. ohne Beanstandung (ich merke nichts davon). Bei eB-Betrieb friert die Verbindung nach einer Weile ein und es bewegt sich nichts im Browser. Erst nach kappen der VPN-Verbindung funktioniert der eB wieder.


Also solltet ihr das Problem in eurer Software suchen und nicht beim VPN-Provider. Tor und VPN-Netz am PC sind zwei vollkommen unterschiedliche Paar Schuhe. Das Ergebnis ist zwar gleich, aber nicht die Herangehensweise.


Warum bitte, soll man VPN nicht ständig (Dauerbetrieb) nutzen? Ich bezahle doch darfür und der Provider sichert auch einen Dauerbetrieb zu ohne große Geschwindigkeitseinbuße. Es ist also doch eure Aufgabe den eB so zu konzipieren, dass er das auch verkraftet.

photo
photo
1

Danke für die Rückmeldung. Habe es mit einer Konfig für einen einzelnen Server probiert, aber leider mit dem gleichen Ergebnis.