Sparkasse iOS app

Virgil Nicolae shared this question 2 months ago
Need Answer

Hi guys,


I'm facing an issue with 2 iOS banking applications and I would appreciate some help.

So, I'm unable to use on iOS the apps for Sparkasse and MLP. Both German financial institutions.

Sparkasse cannot perform any update (but can login) while with MLP I can't even login.

Would it be possible that you can check and update the "German banks" list please?


I have the certificate installed, that's not the problem.


Or, in case that's working for you, little assistance would help. And I've also added the domains as exceptions, but without any luck.


Thanks,

Virgil

Comments (9)

photo
1

Please notice: Since iOS version 10.3 the added eBlocker certificate has to be activated again. Open the iOS settings and navigate to "General" > "About" > "Certificate Trust Settings". You will find the previously added eBlocker certificate there that can be activated again.


Sparkasse+ on iOS and Android works fine with the eBlocker. But indeed there bank servers we don't know.

Does you see any error message telling you maybe the bank servers domain?


You can also use the eBlcoker Expert Tool to analyse which connection was refused by the eBlocker.


I just installed the MLP Financepilot HD App. I have no account, but I tried to connect with a fake user ans password. Of cause that doesn't work, but with our eBlocker Expert Tool I was able to see the eBlocker refused connections.


Please navigate to the eBlocker Settings > Apps and add a "New App definition":


Name it:

MLP Financepilot HD


Disable the eBlocker for the following HTTPS connection:

vr-bankingapp.de

mlp.de


Save the new app definition an activate the new definition now.


Now open the MLP app and sign in. Does it work?

photo
1

Hi Tim,


thanks for clarification and information.

I will try to follow the instructions and post an update after.


Thanks

photo
1

Hello again Tim,


so, I have followed the steps you've explain with success on both cases. For Sparkasse there was some strange domain server that was checked, but was successfully detected by the Expert tool.

As for MLP, same situation: some strange domain server name is called by the MLP application.


There is one thing which I can't figure out: when I check the About->Certificate Trust Settings ... I don't have any eBlocker certificate in there :| .... on the other hand, certificate was deleted and added again (just to be sure).


Any help on this?


Thanks,

Virgil

photo
1

Good morning Tim,


I am in contact with Apple Support as well, concerning this missing certificate in the Trust store.

They asked me to get in direct contact with you, if possible, as they would like to work together and see where the problem is coming from?


Would it be possible to get in direct contact?


Virgil

photo
1

I assume you are using Apple iOS 10.3.2, right? Or did you have a lower iOS version (<= 10.2.x)?


If it is an eBlocker certificate problem please take look into our manual chapter 6.2.4. https://www.eblocker.com/en/user-manual/

Remember: Starting with the iOS version 10.3 (!!!) the added eBlocker certificate has to be activated again in iOS ("General" > "About" > "Certificate Trust Settings").

If you have a lower version, then don't need to activate the eBlocker certificate in "General" > "About" > "Certificate Trust Settings".


What kind of domains you found for the Sparkassen App? If we don't know them, we would like to add them into our German Banks exception list.

photo
1

Hi Tim,


I'm using 10.3.2 .. you are right, certificate should be there....but eBlocker certificate was not there?!

For Sparkasse (I'm using the normal version, free, from the app store, not Sparkasse+): banking-rp4.s-fints-pt-rp.de and IP is 195.140.47.171


For MLP app: ka-app.vr-bankingapp.de with IP 195.200.45.9

photo
1

I have found the solution for the certificate problem!!!

It's a workaround (at least for my case)... where should I post the answer? here or create another forum thread?

photo
1

I'm interested in your solution. You can send it to my @ support@eBlocker.com and I will test it. Thakns.


I just setup an new eBlocker (fresh from the start). Then added the eBlocker certificate to my iPad (iOS 1.3.2) and everything works fine (like written in our handbook chapter 6.2.4)

photo
1

Thanks. I will send you the email in the next minutes.

The setup, as described, is ok. My case was little different.

Maybe can help you later.


V.

photo