Managed Switch: eblocker nicht mehr erreichbar

Löt_Lümmel shared this question 2 months ago
Need Answer

Servus Gemeinde,

Mein Eblocker ist nach monatelangem problemlosen Betrieb plötzlich nicht mehr per Browser erreichbar.

- es taucht kein Symbol auf irgendwelchen websites auf (auch nicht über setup.eblocker.com)

- ist über seine (statische) ip nicht erreichbar

- auch nicht über die Notfall-ip

- Der Eblocker (auf einem Banana Pi M2, ja, natürlich resets ausgeführt...) ist im manuellen Modus installiert mit statischer ip, die bei den entsprechenden Rechnern als Router-Adresse eingetragen ist. Das surfen auf diesen Geräten klappt (offenbar über den Eblocker) problemlos, nur kann ich den Eblocker nicht mehr über den Browser aufrufen, das Symbol taucht nicht mehr auf und der Eblocker blockt nicht mehr.


Ich sehe ggf. einen (zeitlichen/kausalen?) Zusammenhang mit der Inbetriebnahme eines "managed switch", den ich einsetzen musste, nachdem mein alter Switch in Rauch aufgegangen war. (defektes Netzteil).

Der neue (managed) switch läuft auch mit statischer ip, die dort einstellbare ip für den Router hatte ich leer gelassen (default 0.0.0.0.). Auch das eintragen der Eblocker-IP an dieser Stelle brachte keinen Erfolg.

Wichtig zu wissen ist noch, dass ich in meinem Netz mit ausschließlich statischen Ip-Adressen bei einigen Geräten den Eblocker als Router eingetragen habe, bei anderen Geräten (bei denen keine Werbeblocker vonnöten sind) habe ich die Fritzbox eingetragen. Das hat bisher hervorragend funktioniert.

Die Gretchenfrage ist nun, was ich am managed switch einstellen oder ausstellen muss, um den Eblocker wieder ins Boot zu holen...

Oder gibt es andere Ideen?


Schon mal Danke für Eure Hilfe!


der Löt_Lümmel

Comments (6)

photo
1

Welchen manages Switch setzen Sie ein. das wäre ein interessante Information, damit wir uns die Anleitung zu dem Switch auch ein mal ansehen können.

Frage: Können Sie den Switch in seinen Einstellungen auf unmanaged umstellen?

Generell gilt folgendes:

Wenn Sie ein komplett von Hand aufgebautes Netzwerk haben, also auf einen DHCP Server ganz verzichten, dann müssen bei den Endgeräten der eBlocker als Gateway und beim eBlocker der Router als Gateway eingetragen werden.

photo
1

Es handelt sich um einen ZYXEL 28 Port, GS1920-24 Switch.

Management kann man meines Wissens nach nicht generell ausschalten, nur in den entsprechenden Bereichen.

Ich habe aber in der Zwischenzeit etwas heraus gefunden:

Nachdem der Eblocker-Banana-Pi auch bei direktem Anschluss an einen Rechner nicht über seine Notfall-Ip-Adresse erreichbar war, habe ich vermutet, dass der Eblocker richtig "einen abgekriegt hatte".

Ich habe daraufhin die SD-Karte neu formatiert und ein frisches Betriebssystem drauf gespielt (warum kann man eigentlich seine Eblocker-Einstellungen nicht abspeichern / einlesen für so einen Fall?).

Also alle Einstellungen von Hand wieder hergestellt.

Und siehe da: der Eblocker arbeitet wieder -mit den unveränderten Einstellungen im managed switch- so, wie er soll.

Es liegt also scheinbar nicht am switch selbst.

Nach meiner Einschätzung sind drei Ursachen möglich/wahrscheinlich:

1) der Eblocker hat sich beim Austausch des switches irgendwie "verschluckt", was allerdings auch durch einige Neustarts nicht behoben werden konnte. So wäre der zeitliche Zusammenhang der Probleme mit dem switch-Wechsel erklärbar.

2) Der Eblocker hat möglichweise zeitgleich / in der Nacht selbstständig in Update gefahren und sich dabei "verschluckt".

3) SD-Karte ist defekt oder die Firmware war geschrottet (die Karte klappt aber wieder einwandfrei mit dem neu aufgespielten Betriebssystem)

viele Grüße,

der Löt_Lümmel

photo
1

Könnte ein Datenbank Problem beim eBlocker gewesen sein.


Sollte das wieder passieren, dann kann man mit Hilfe eines USB 2.0 Sticks einen Status Bericht schreiben lassen, sofern minimum die eBlockerOS Version 1.0.6 eingesetzt wird.


(Achtung: löschen Sie ggf. vorher vom Stick die Datei "eblocker-factory-reset.txt")


- Trennen Sie den eBlocker vom Strom, lassen Sie aber das Netzwerkkabel am eBlocker und am Router angeschlossen.

- Stecken Sie einen USB-Stick an den eBlocker

- Verbinden Sie den eBlocker mit der Stromversorgung

- Warten Sie mindestens 3 Minuten.


Danach können Sie den USB-Stick abziehen und am Computer anstecken. Auf dem Stick sollte sich nun eine Datei "eblocker-status.html" befinden. Bitte senden Sie uns diese zu.

photo
1

...(warum kann man eigentlich seine Eblocker-Einstellungen nicht abspeichern / einlesen für so einen Fall?)...

Ist hier zwar OT, aber wenn es Löt_Lümmel schon mal angesprochen hat, und ich es vor Monaten auch schon

mal geschrieben habe:


-Backup/Restore, möglichst incl. der ssl schlüssel - die "Standardschlüssel" könnten durchaus über einen Restore zurück kopiert und wieder verwendet werden.


Was ist daraus geworden?


Gruß

photo
1

auch von mir die dringende Bitte, endlich diese backup/restore Grundfunktionalität zu realisieren - gerade solange das eBlocker-interne Management der SSL-Listen so buggy ist, wie es ist (siehe separater thread)


es kostet uns Nutzer ienen unendlichen Zeitaufwand all unsere Settings (insbesondere die benutzerdefinierten Apps) erneut herauszufinden und definieren


Must Funktionalität!

photo
1

Vielen Dank für den ausdrücklichen Wunsch! Auch hier im Support ist das ein großes Wunsch-Feature.

Kleines Interna: Letzte Woche haben wir in unserem großen Entwicklungs-Wochenmeeting der Backup-Funktion eine neue höhere Priorität gegeben.

Wir arbeiten derzeit an dem Konzept und beginnen dann mit der Entwicklung.

photo