I can access eBlocker but I can't see the eBlocker icon on any webpage in any browser on any device

Keith K. shared this question 1 year ago
Need Answer

I'm at a loss. I have my eBlocker connected directly to my router and I can access the eBlocker settings. However, the eBlocker is not actually blocking any sites and I don't see any eBlocker icon on any browser using any device. So basically it's being found on my network just fine, but it basically isn't working. Any ideas of what I can try? Below I've answered all the questions on the "Please read this first" page.


Network Configuration:

- Router: Asus RT-AC5300 (UPnP turned off)

- eBlockerOS version : 0.9.3-8

- No device allows me to see the eBlocker icon on any browser

- Devices: MacBook Pro running OSX Yosemite (10.10.5) and iPhone 5 running iOS (9.3.5)

- eBlocker is running in manual mode

- I'm using a LAN and the eBlocker is attached directly to the router

- My network setup is: WAN->router->network switch (managed)

- I DO NOT see the eBlocker icon on http://setup.eblocker.com

- It fails on Safari, Firefox, and Chrome (all updated to current versions)

- I DO NOT have SSL-function turned on

- I CAN access eBlocker settings just fine, however.

- The eBlocker DOES appear on my list of devices on my router just fine

- All of the power LED and 2 network LEDs on the eBlocker board are working fine and flashing.

Comments (5)

photo
1

Did you build your own eBlocker? If so, which board did you used?


Your switch is managed. So have you changed the network settings there? Is your router or the eBlocker the Gateway?

Is your MacBook connected to the switch?

Did you restart your MacBook and iPhone after setting the eBlocker to manual network modus?

photo
1

Good questions that I didn't think to answer at first.


- I did not build my eBlocker, it is the first series that they shipped out with the Kickstarter campaign (the one's in the clear plastic case). I'm not sure but I think it might be a Banana Pi board (it's marked with BPI on the board).

- My switch is a smart managed switch, but I'm not using that feature at the moment, so all of the network settings (DHCP and NAT) are being assigned by the router.

- My router is the Gateway and not the eBlocker

- May MacBook and other devices are all connected via WiFi and not directly connected to the switch. The only thing I have connected to the switch is a NAS and security cameras.

- I DID NOT restart my MacBook or my iPhone after setting the eBlocker to manual network mode (I should've done that), so I'll try that tonight when I get home from work.


I will note that when my network was much simpler about 6 months ago when I first got the eBlocker (only Apple Airport routers and nothing else), the eBlocker worked fine in Automatic mode and I didn't have to restart any devices. Unfortunately, my network is not using the default IP addresses like (10.0.X.X, 192.168.X.X, etc). I'm now assigning my own custom address which is why I had to switch the eBlocker into manual mode - it couldn't be found on the network automatically otherwise.

photo
1

UPDATE: Restarting the devices did not solve the problem, unfortunately.


- Does the eBlocker need the router to be in UPnP mode?

- Does eBlocker need to be the Gateway to the rest of my network?


It's weird that I can access the eBlocker just fine (settings, etc) and my router sees it...but eBlocker simply isn't working (ie. blocking website ads, etc).


I'm at a loss...right now, it's sort of just a idle device.

Any help is appreciated.

photo
1

Hi Keith,


the eBlocker does not need the router to be in UPnP mode.


But the eBlocker must indeed be the gateway for all devices it should protect.


This can be achieved in three ways:


  • Run the eBlocker in automatic network mode. This is the recommended setup, unless your router or your network configuration demand something else.
  • Run the eBlocker in the so called manual network mode. In this scenario, the eBlocker is the DHCP server for all devices, so that it can assign itself as gateway for all these devices. In this setup, it is important to switch off the DHCP server in the router to avoid conflicts.
  • Third possibiliy is to do the network configuration all alone and not use DHCP. Again, the eBlocker must be the default gateway for all protected devices. In this setup, you lose the functionality to (de)activate the eBlocker for single devices via the eBlocker console. You would have to change the default gateway of the devices manually.


My understanding is that you use the manual network mode, but the router is still the DHCP server?


This will not work, unless you can advise the router to tell all other devices to use the eBlocker as gateway.

Thanks

photo
photo
1

Hi Keith,


please take a look to this knowledge base article:

http://user.forum.eblocker.com/knowledge-base/article/manual-network-configuration_1


"Once the eBlocker is manually configured it can be used as the Internet gateway for your network clients."