Gerät stets dieselbe IP-Adresse zuweisen

Christoph Sieger shared this question 2 months ago
Answered

Mein eBlocker ist als DHCP-Server eingerichtet (eBlocker Family, OS 1.11.9). Vor ein paar Tagen hat mein PC keine IP-Nummer mehr erhalten (d. h. automatisch die IP-Nummer 169.x.etc. von Windwos). Erst nachdem ich die Option "Gerät stets dieselbe IP-Adresse zuweisen" für den PC im eBlocker deaktiviert habe, hat der PC wieder eine neue IP-Adresse erhalten (danach habe ich die Option wieder aktiviert und alles läuft seither wieder in Ordnung).

Kann es sein, dass wenn einmal die IP-Adresse 169.x.etc. für ein Gerät im Netzwerk vergeben wird (da für ein Moment der eBlocker als DHCP-Server nicht erreichbar ist), der eBlocker mit der aktivierten Option "Gerät stets dieselbe IP-Adresse zuweisen" in Folge immer wieder die 169.x.etc. vergibt?

Comments (5)

photo
1

Der eBlocker weist keinem Gerät eine IP-Adresse mit 169. am Anfang zu. Das sind die IP-Adressen, die sich Geräte selber zuweisen, wenn Sie keinen DHCP-Server im Netzwerk finden.

photo
1

Bei mir tritt dieser Fehler exakt auch so auf, wenn die Fritz!Box 6490 als DHCP arbeitet. Ist schon seit Monaten so und begann mit einem der älteren Updates. Frage wurde nie zufriedenstellend beantwortet. Hoffe jetzt auf das neue Update.

Betrifft nur Windows-Geräte, aber verlässlich in unregelmäßigen Abständen von 1 bis 2 Wochen. Muß dann immer mit dem Android-Tablet auf den Router zugreifen, um die feste IP freizugeben. Auf Dauer nervt das gewaltig.

Interessant zu wissen, daß das auch mit dem eBlocker als DHCP passiert.

photo
1

Wie schon gesagt, wenn ein Windows eine IP-Adresse mit 169.254.xx.xx zugewiesen bekommt, dass heißt es, dass der Windows Rechner keinen DHCP-Server erreicht hat. Das passiert gerne mal bei Windows, wenn dieser aus dem Schlaf / Hibernation aufwacht, aber auch mal beim normalen Start von Windows. Der Grund dafür kann sein, dass die Netzwerkschnittstelle bei der DHCP-Server abfrage noch nicht richtig hochgefahren war.

photo
1

Nach meinem Verständnis gehen die Antworten am Problem vorbei. Das eigentlich Problem ist ja, daß Windows keine IP bekommt, da der eBlocker das gelegentlich aus unerfindlichen Gründen verhindert bzw. den Router (DHCP) temporär aus dem Tritt bringt (IP angeblich doppelt). Natürlich vergibt der eBlocker nicht plötzlich Adressen aus einem anderen Adressbereich.

Werden sehen, ob das morgen nach dem aktuellen Update besser oder schlimmer wird. Ist definitiv ein eBlocker-Problem. In den 20 Jahren vor eBlocker bzw. in dessen Startphase kam so etwas nie vor.

photo
1

Gerne möchte ich nochmals auf das Thema zurückkommen. In der Tat kann es sein, dass der DHCP Server nicht erreicht wird und dann die besagte 169.x.x.x Nummer vergeben wird. Das Problem ist jedoch, wenn ich dann das Gerät im eBlocker unter "Geräte" anschaue, sehe ich, dass 2 IP-Nummern bei diesem Gerät hinterlegt sind (192.168.x.x und die 169.x.x.x). Ist dieses Verhalten korrekt?

Im Übrigen hatte ich dieses Problem in der Vergangenheit nicht, als noch mein Router der DHCP-Server war. Kann es sein, dass im eBloker diesbezüglich ein Problem vorliegt?