eBlocker funktioniert unter CyberGhost nicht

Holger E. shared this question 6 months ago
Need Answer

Hatte nach dem letzten Post die Hoffnung das VPN mit dem Update unterstützt wird. Leider ist dem nicht so oder muss ich irgend etwas beachten?

Best Answer
photo

Und ich wollte gerade einen Dankeschön-Post dafür absetzen, dass der eBlocker so reibungslos mit Cyberghost zusammenarbeitet!


Die Einrichtung ist leider etwas "komplizierter", der Aufwand hält sich aber in Grenzen.


1. Logge dich in deinen Cyberghost-Account ein

2. Unter "Meine Geräte" füge ein neues hinzu, dabei wählst du "andere Geräte"

3. Klicke "Separate Anmeldedaten erzeugen"

4. Unter "Anmeldedaten für Linux, Router etc" wählst du OpenVPN (UPD) sowie dein Wunschland.

5. Lade die Konfigurationsdatei herunter und extrahiere sie.

6. Jetzt musst du leider basteln, da der eBlocker derzeit keinen manuellen Zertifikatimport erlaubt. Er geht davon aus, dass die Zertifikate in der *.ovpn hinterlegt sind. Also bearbeitest du diese Datei, z.B. mit PSPad.

7. Entferne "ca ca.crt cert client.crt und key client.key"

8. Binde nun die Zertifikate manuell wie folgt ein:


<ca>

-----BEGIN CERTIFICATE-----

....

-----END CERTIFICATE-----

</ca>

<cert>

-----BEGIN CERTIFICATE-----

....

-----END CERTIFICATE-----

</cert>

<key>

-----BEGIN PRIVATE KEY-----

...

-----END PRIVATE KEY-----

</key>


[Zur Klarstellung: im Segment <ca> fügst du den Inhalt der ca.crt ein, unter <cert> den Inhalt der client.crt und unter <key> den Inhalt der Datei client.key]

9. Datei abspeichern und den Setupassistenten des eBlockers ausführen

10. Konfiguration importieren, Zugangsdaten aus deinem Cybgerghostaccount übernehmen (Achtung, nicht deine Logindaten, sondern die unter Punkt 4 aufgezeigten!)

11. Verbindung testen und hoffentlich freuen!

Comments (26)

photo
4

Und ich wollte gerade einen Dankeschön-Post dafür absetzen, dass der eBlocker so reibungslos mit Cyberghost zusammenarbeitet!


Die Einrichtung ist leider etwas "komplizierter", der Aufwand hält sich aber in Grenzen.


1. Logge dich in deinen Cyberghost-Account ein

2. Unter "Meine Geräte" füge ein neues hinzu, dabei wählst du "andere Geräte"

3. Klicke "Separate Anmeldedaten erzeugen"

4. Unter "Anmeldedaten für Linux, Router etc" wählst du OpenVPN (UPD) sowie dein Wunschland.

5. Lade die Konfigurationsdatei herunter und extrahiere sie.

6. Jetzt musst du leider basteln, da der eBlocker derzeit keinen manuellen Zertifikatimport erlaubt. Er geht davon aus, dass die Zertifikate in der *.ovpn hinterlegt sind. Also bearbeitest du diese Datei, z.B. mit PSPad.

7. Entferne "ca ca.crt cert client.crt und key client.key"

8. Binde nun die Zertifikate manuell wie folgt ein:


<ca>

-----BEGIN CERTIFICATE-----

....

-----END CERTIFICATE-----

</ca>

<cert>

-----BEGIN CERTIFICATE-----

....

-----END CERTIFICATE-----

</cert>

<key>

-----BEGIN PRIVATE KEY-----

...

-----END PRIVATE KEY-----

</key>


[Zur Klarstellung: im Segment <ca> fügst du den Inhalt der ca.crt ein, unter <cert> den Inhalt der client.crt und unter <key> den Inhalt der Datei client.key]

9. Datei abspeichern und den Setupassistenten des eBlockers ausführen

10. Konfiguration importieren, Zugangsdaten aus deinem Cybgerghostaccount übernehmen (Achtung, nicht deine Logindaten, sondern die unter Punkt 4 aufgezeigten!)

11. Verbindung testen und hoffentlich freuen!

photo
1

Na, wenns soooo einfach ist.

Ich weiß nicht wer naiver war. Die Entwickler oder die Kunden? Plug and Play - echt ein schöner Gedanke.

photo
2

Naja, die Konfiguration anzupassen dauert vielleicht 5 Minuten (zugegeben: wenn man weiß wie es geht). Cyberghost wird aber auch nicht explizit als kompatibel aufgeführt, deswegen bin ich da entspannt.

Es wäre natürlich schön, wenn das eBlocker-Team den Zertifikatsimport mit in den VPN-Assistenten aufnehmen würde, nach dem parsen der *.ovpn ist es ja für den eBlocker anhand der enthaltenen infos "ca ca.crt cert client.crt und key client.key" ein Leichtes zu erkennen, dass offensichtlich Zertifikate importiert werden müssen. Wer weiß, vielleicht findet sich ja schon bald entsprechende Felder.

Ach so: ich habe dir gerne geholfen.

photo
1

ich habe es gestern mit dem Editor wie oben beschrieben versucht; leider ohne Erfolg. Mit PSPad hats geklappt. Habe wohl mit dem Editor das ein oder andere Leerzeichen in der Datei nicht entfernt. Egal, jetzt funktionierts.

Danke Thomas!

photo
1

@Thomas

Sorry. Bin ein bisserl schräg drauf heute. Da ist wohl eine Grippe im Anmarsch :-(

DANKE dir. Hat bestens funktioniert.


photo
2

Schön, dass es auch bei euch funktioniert und


@Holger E. gute Besserung! ;-)

photo
1

Hallo,

ich habe den Eblocker im manuellen Mode laufen, da ich die dummerweise FritzBox7490 habe.

Der Cyberghost funktioniert nicht.

Leider habe ich die Schritte zur Konfiguration nicht verstanden:

"

9. Datei abspeichern und den Setupassistenten des eBlockers ausführen

10.

Konfiguration importieren, Zugangsdaten aus deinem Cybgerghostaccount

übernehmen (Achtung, nicht deine Logindaten, sondern die unter Punkt 4

aufgezeigten!)

"

Könnt ihr das einem Laien mal etwas genauer erklären?

Wo finde ich den Setupassistenten?

Oder löst dies mein Problem gar nicht?

photo
1

Moin Hartmut,


ich bin mir nicht sicher ob ich deine Frage richtig verstehe.

Falls du tatsächlich den eBlocker-Einrichtungsassistenten suchst: dieser findet sich unter


IP-Anonymisierung --> VPN-Netzwerk --> neuer VPN Anbieter


Gruß Thomas

photo
2

Hallo Thomas,

danke für die Antwort.

Jetzt habe ich es gefunden, allerdings nicht der gewünschte Erfolg :-(

openvpn.ovpn entsprechend der Anleitung oben genommen und die Abschnitte aus den Dateien eingefügt (alle Leerzeilen gelöscht) - alles mit PSPad


Abgespeichert

Mittels Eblocker Assistenten importiert.

Cyberghost Name und Passwort eingetragen

Name und Beschreibung vergeben (habe Name:Cyberghost und Beschreibung:VPN Cyberghost genommen)

Land gewählt (gleiches, wie unter Cyberghost-Login gewähltes)

Verbindungstest mit Timeout:

Wed Feb 15 19:10:22 2017 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

Wed Feb 15 19:10:22 2017 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this

Wed Feb 15 19:10:28 2017 AUTH: Received control message: AUTH_FAILED

Wed Feb 15 19:10:38 2017 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

Wed Feb 15 19:10:44 2017 AUTH: Received control message: AUTH_FAILED

Wed Feb 15 19:10:54 2017 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

Wed Feb 15 19:11:00 2017 AUTH: Received control message: AUTH_FAILED

Wed Feb 15 19:11:10 2017 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts

Wed Feb 15 19:11:16 2017 AUTH: Received control message: AUTH_FAILED

photo
1

Hat sich erledigt...

man muss nur den richtigen Login und das richtige Passwort nehem *grummel

Mal schauen, ob alles so läuft


Nachtrag: Erste Versuche sind super!

photo
1

Na darauf hatte ich doch extra hingewiesen :-P Egal -schön, dass es klappt!

photo
1

Hallo Holger, Thomas und Hartmut,

ich hab mal eine Frage an euch ob Ihr auch das Problem habt, dass die manuelle VPN-Verbindung sich einfach mal verabschiedet?

D.h. ich habe VPN einzelnen Geräten zugewiesen und sagen wir mal so, am nächsten Tag funktioniert die VPN Verbindung nicht mehr.

Ich muss die komplette Verbindung wieder löschen und wieder neu einstellen.

Das Problem tritt dann später (Zeitfenster nicht klar) wieder auf.

Habt Ihr auch so ein Phänomen?

photo
1

Hallo mad,

hatte heute erst mein 2. login mit VPN.

Am Anfang war es auch nicht da. Hab dann IP-Anonymisierung Aus und angeschaltet, dann ging es.

Ich glaube aber es braucht einfach ein wenig mehr Zeit für den Verbindungsaufbau.

Ich beobachte das...

photo
1

Nach einigen Tagen mit Cyberghost kann ich das bestätigen:

Ich muss nach jedem Hochfahren des Rechners die IP-Anonymisierung Aus- und wieder Einschalten.

Was kann man tun?

photo
1

Hallo mad,

ich habe das Problem immer noch.

Ich muss jedesmal die IP-Anonymisierung des Gerätes Aus- und wieder Anschalten um zu connecten.

@all: ist dies lösbar?

photo
1

Kann es sein das Cyberghost die Verbindung nach einer bestimmten Dauer der Inaktivität selber beendet?

photo
1

Hallo Tim,

nicht nach einer bestimmten Zeit. Die Verbindung hält, solange ich den Rechner an habe.

Beim nächsten Start habe ich wieder die original IP.

Im Eblocker ist die IP-Anonymisierung immer eingeschaltet.

Erst IP-Anonymisierung Aus- und wieder Einschalten bringt Cyberghost wieder in Aktion.

photo
1

Ich habe das jetzt versucht mit einigen Kombinationen nachzustellen, aber bei mir scheint das ohne Probleme zu funktionieren. Einen CyberGhost Zugang habe ich aber zum testen leider nicht.

Welches Betriebssystem nutzen Sie und welche Browser setzen Sie ein?

photo
1

ich habe Windows 10 64Bit und den Firefox

photo
1

Hm, mit Perfect Privacy habe ich das Problem nicht.


@all : Kann das Problem jemand bestätigen?

photo
1

Ich zumindest nicht, bei mir hält die Verbindung auch nach einem Reboot.

photo
1

Bei funktioniert Perfect Privacy leider nicht. Ich habe folgende Konfigurationsdatei von Perfect Privacy versendet: UDP AES-256-CBS (mit einigen anderen habe ich es auch versucht, z.B. TCP). Ich erhalte folgende Fehlermeldung beim Verbindungstest:


Thu Apr 27 10:45:32 2017 NOTE: the current --script-security setting may allow this configuration to call user-defined scriptsThu Apr 27 10:45:32 2017 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent thisRTNETLINK answers: Operation not supportedThu Apr 27 10:45:38 2017 Linux ip -6 addr add failed: external program exited with error status: 2


Ich verwende Version 1.3.3, welche heute erschienen ist. Mit VPN über Private Internet Access hatte ich ebenfalls

Ich verwende eBlocker V 1.3.3, welche heute erschienen ist. Mit VPN über Private Internet Access hatte ich ebenfalls keinen Erfolg. Ich konnte zwar das Zertifikat importieren (neu möglich mit V 1.3.3), aber die Verbindung ist dennoch nicht zu Stande gekommen.


Einzig mit NordVPN kann ich mich im Moment verbinden, da klappt es einwandfrei.

photo
1

Versuchen Sie bitte die Perfect Privacy Dateien:

  • Protokoll: UPD - Verschlüsselung: ACE-128-CBC
  • Protokoll: UPD - Verschlüsselung: ACE-256-CBC

photo
1

Ich habe nun nochmals folgendes ausprobiert:


  • UDP - Verschlüsselung AES-256-CBC (ACE-256-CBS gibt es nicht, ist wahrscheinlich ein Schreibfehler. Die obenstehende Fehlermeldung bleibt bestehen.
  • UDP - Verschlüsselung AES-128-CBC. Geht ebenfalls nicht, ich erhalte folgende Fehlermeldung:


Thu Apr 27 13:41:44 2017 NOTE: the current --script-security setting may allow this configuration to call user-defined scriptsThu Apr 27 13:41:44 2017 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent thisThu Apr 27 13:41:48 2017 WARNING: 'cipher' is used inconsistently, local='cipher AES-128-CBC', remote='cipher AES-256-CBC'Thu Apr 27 13:41:48 2017 WARNING: 'keysize' is used inconsistently, local='keysize 128', remote='keysize 256'RTNETLINK answers: Operation not supportedThu Apr 27 13:41:50 2017 Linux ip -6 addr add failed: external program exited with error status: 2


Muss man allenfalls andere Zugangsdaten verwenden als diejenigen, welche man für das Login ins Knoto verwendet?

photo
1

Kann es sein, dass Sie eventuell ältere OpenVPN Dateien von Perfect Privacy nutzen?

Laden Sie bitte die aktuellen OpenVPN Dateien herunter. Klicken Sie auf der Perfect Privacy Kunden Seite auf Download > auf das Router Icon und dann unter eBlocker auf Anzeigen.


Folgende OpenVPN Dateien habe ich heute getestet und diese funktionieren mit dem eBlockerOS 1.3.3


  • Protokoll: UPD - Verschlüsselung: ACE-128-CBC
  • Protokoll: UPD - Verschlüsselung: ACE-256-CBC


Unter Username tragen Sie ihren Perfect Privacy Usernamen ein und als Passwort nutzen Sie das Passwort, mit dem Sie sich auch im Kundenbereich anmelden.

photo
1

Ok, ok, ok, ok... Asche auf mein Haupt. Ich habe nicht auf das Router-Icon geklickt, sondern die OpenVPN-Dateien für Windows verwendet. Mit diesen funktioniert es anscheinend nicht! Nun funktioniert es perfekt!


Übrigens: Ein ganz herzliches Dankeschön für den guten und raschen Support, nicht nur bei dieser Anfrage!

photo