FritzBox 7490 WLAN issue

The FritzBox 7490 has a confirmed bug, which results in very slow speeds when the eBlocker is connected. This bug is not eBlocker specific but is the result of a non standard routing when using WLAN in the particular 7490. Other FritzBox models are not affected and the manufacturer (AVM) is aware of the bug.

Workaround

The issue only occurs in automatic network mode, so we recommend to configure eBlocker to use the manual mode. There is a step-by-step guide (in German).

You can also add another WLAN access point to your network to connect your WLAN clients.

Technical background

Clients connected to the WLAN of a FritzBox 7490 are affected by a routing problem. While HTTP connections work fine, other protocols, for example SSL (port 443) or FTP (ports 20 and 21) are not routed to the Internet.

If another WLAN access point is connected to the FritzBox 7490's LAN, the problem does not occur.

The problem is not related to the eBlocker software. It can be reproduced by configuring a Linux machine in the FritzBox 7490 LAN with IPv4 forwarding (sysctl -w net.ipv4.ip_forward=1) and setting its IP address as the gateway on the client.

It is important to note that ICMP packets are routed without any problems. As a result, tests with Ping and Traceroute (when ICMP is used for probe packets) are successful. When UDP or TCP packets are used, however, the FritzBox 7490 returns those packets back to the gateway (i.e. the eBlocker) if they were originally received from a WLAN client.

The following table shows the Traceoute behaviour. (Note that the tool "tracert" on Windows always uses ICMP, so you will not observe the problem.)

Client connected toTraceroute test with protocolFritzBox 7490Other FritzBoxes and routers
LANICMPOKOK
LANUDPOKOK
WLANICMPOKOK
WLANUDPEndless loop between eBlocker and FritzBoxOK

We have an open ticket with the AVM support (ticket ID 80457).

Is article helpful?